/-----------------------------------------------------------\ | Procedure to run Veritas NetBackup client in OpenBSD i386 | \-----------------------------------------------------------/ On the OpenBSD box (future NetBackup client), execute the following: -------------------------------------------------------------------- _ cd /usr/ports/emulators/redhat/base/ && make install clean CLEANDEPENDS=Yes _ Add the following entries to system configuration files: # tail -n 2 /etc/hosts /etc/inetd.conf /etc/services ==> /etc/hosts <== www.xxx.yyy.zzz YOUR_NETBACKUP_SERVER www.xxx.yyy.zzz THIS_NETBACKUP_CLIENT ==> /etc/inetd.conf <== bpcd stream tcp nowait root /usr/openv/netbackup/bin/bpcd bpcd vopied stream tcp nowait root /usr/openv/bin/vopied vopied ==> /etc/services <== bpcd 13782/tcp # NetBackup bpcd vopied 13783/tcp # NetBackup vopied _ Extract the needed files somewhere (you can get 4.5 binaries from this site): # cd $SOMEWHERE && tar zxpf $THIS_DIR/NetBackup_client_linux.tgz _ Make the link /usr/openv: # ln -s $SOMEWHERE/NetBackup_client_linux /usr/openv _ Write the NetBackup configuration file (adapt it to your names): # echo "SERVER = ${YOUR_NETBACKUP_SERVER}" > /usr/openv/netbackup/bp.conf # echo "CLIENT_NAME = `hostname`" >> /usr/openv/netbackup/bp.conf _ Enable linux emulation in OpenBSD kernel: # sysctl kern.emul.linux=1 (You can do it permanently in modifying /etc/sysctl.conf) _ Populate /emul/linux/etc/mtab with some informations (even fake). It prevents jobs from failling with errors about the "setmntent" linux syscall. For exemple, I put: # cat /emul/linux/etc/mtab /dev/sd0a / /dev/sd0d /usr /dev/sd0e /usr/local /dev/sd0f /var /dev/sd0g /data _ Reload inetd: # pkill -HUP inetd _ On the NetBackup server, launch some jobs. If they fail or corrupt your data, do not blame me or Veritas. You are on your own. Notes: ------ _ The NetBackup server has to know the client hosts using /etc/hosts or the DNS entries.